+48 667 254 321
[email protected]

Language:

Will my mobile device work with Photon?

List of compatible and tested devices

Check the list below to make sure Photon applications will work properly on your device. These are tablets and phones that we have personally checked and we are 100% sure about their compatibility. We are constantly working on expanding the list with new equipment.

Do not worry – if your device is not on the list, it probably only means that we have not tested it yet.

At the bottom of the page, you will find a list of equipment on which we have seen various errors – these devices are not recommended for work with Photon.

Devices with Android OS

Basic requirements:

  • Android version: 4.4+
  • Bluetooth 4.0+
Tablets

models:

Huawei MediaPad T1

Huawei MediaPad T3

Samsung Galaxy Tab E 9.6

Samsung Galaxy Tab 3

Samsung Galaxy Tab 4

Lenovo Tab 2 A10-70l

Lenovo Tab3 A7

Lenovo Tab4

LG G Pad 8,3'

Phones

models:

Samsung Galaxy S8

Samsung Galaxy S7

Samsung Galaxy J3 (2017)

Samsung A5 (2017)

LG G6

LG K8

LG Spirit 4G LTE

Huawei Honor 8

Huawei P10 Lite

Huawei P9 Lite (2017)

Huawei Y2

HTC 10

Xiaomi Redmi 4X

Xiaomi Redmi Note 3

Sony Xperia Z3

Sony Xperia Z3 Plus

Sony Xperia Z2

Motorola G6+

Apple iOS devices

Basic requirements:

  • OS version: 8.0+
  • Bluetooth 4.0+
Tablets

models:

iPad mini 2, 3, 4

iPad Pro 9.7, 10.5, 12.9

Phones

models:

iPhone X

iPhone 7, iPhone 7 Plus

iPhone 8, iPhone 8 Plus

iPhone SE

Device blacklist

List of devices that does not work correctly with Photon:

Samsung Galaxy J3 (connectivity problems)

Samsung Galaxy Tab A 7.0 (connectivity problems)

Medion LifeTab P8911 (connectivity problems)

Huawei P8 Lite (connectivity problems)

Blow BlackTAB 7.4 HD (connectivity problems)